Bug 10075 - eric4 segfault
Summary: eric4 segfault
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 3
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Keywords: Triaged
Depends on:
Reported: 2013-05-12 18:53 CEST by Ãtienne G
Modified: 2015-03-31 16:06 CEST (History)
6 users (show)

See Also:
Source RPM: eric4
Status comment:


Description Ãtienne G 2013-05-12 18:53:25 CEST
I install eric4 v4.5.6 3.mga3 on a x86_64. It not runs and write in a konsole "Erreur de segmentation".
It make the same when I install a i586 version on my x86_64. No error during installation.
Comment 1 hans werner may 2013-05-23 20:34:14 CEST
Can confirm this, kernel says: 

May 23 20:13:56 localhost kernel: python[3865]: segfault at 0 ip 00007f71338c8c79 sp 00007fff84c88ea0 error 4 in libQtWebKit.so.4.10.0[7f7133480000+1f7d000]

CC: (none) => nc-mayha2

Comment 2 Ãtienne G 2013-05-24 12:23:54 CEST
I would precise : I install Eric4 from source (http://eric-ide.python-projects.org/, version 4.5.11) and it runs. Python, qt and python-qt are installed from Mageia repository.
Comment 3 hans werner may 2013-05-24 12:58:04 CEST
Can confirm this also, installing from source works fine, Eric4 is running now. So it must be a bug in Mageia3.
Manuel Hiebel 2013-05-24 20:08:09 CEST

Keywords: (none) => Triaged
CC: (none) => fundawang, matteo.pasotti
Source RPM: (none) => eric4

Comment 4 Keith Preston 2013-06-05 20:38:50 CEST
More confirmation. x86_64 version of eric4 segfaults. gdb says: 
Program received signal SIGSEGV, Segmentation fault.
0x00007fffed195c79 in WebCore::initializeWebCoreQt() ()
   from /usr/lib64/libQtWebKit.so.4

Installed version 4.5.11 from source and it runs fine.

CC: (none) => mag.4.shrdlu

Brad Fonseca 2013-06-25 04:49:57 CEST

CC: (none) => brad.fonseca

Comment 5 Brad Fonseca 2013-06-25 04:59:11 CEST
I can confirm that that I have experienced the same issue on an i586 architecture.
Matteo Pasotti 2013-06-26 19:22:30 CEST

CC: matteo.pasotti => (none)

Comment 6 Samuel Verschelde 2013-09-08 11:17:56 CEST
Does it work if you rebuild the source RPM from Mageia 3 itself?

CC: (none) => stormi
Resolution: (none) => OLD

Comment 7 Samuel Verschelde 2013-09-08 11:18:39 CEST
oops, didn't mean to close it

Resolution: OLD => (none)

Comment 8 Ãtienne G 2013-09-08 13:11:04 CEST
> Does it work if you rebuild the source RPM from Mageia 3 itself?

Same error when install rpm rebuilt. Same error with manual install (with python) from tar.gz include in eric4.src.rpm.

I think you didn't choice the good version!
Samuel Verschelde 2013-09-08 13:44:17 CEST

CC: (none) => matteo.pasotti

Comment 9 Marja Van Waes 2015-03-31 16:06:09 CEST
Mageia 3 changed to end-of-life (EOL) status 4 months ago.

Mageia 3 is no longer maintained, which means that it will not receive any further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of Mageia
please feel free to click on "Version" change it against that version of Mageia
and reopen this bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

The Mageia Bugsquad

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.